Application Compatibility

* VPN is required for off-campus connection with some exclusions for highly secure systems.

Web Applications

ApplicationFirefoxInternet ExplorerSafariChromeVPNGoVPNVPN Required*
Banner 9 (Internet Native Banner) Latest Latest Latest Latest Supported Supported Y
Banner (Self Service Banner) Latest (recommended) 11 (recommended) Latest Latest Not Required Not Required N
Banner Workflow Latest Latest Latest Latest Supported Supported Y
Budget Entry Spreadsheet (BES) Latest version 11 Not Supported Not Supported Supported Supported Y
Cognos not supported 11 Latest (Note that Safari users may experience issues with reports going to Excel.) Latest Supported Supported Y
Customize my VoIP phone settings         Supported Supported Y
Elearning (Desire 2 Learn) Latest and ESR Not Supported Latest Latest Not Required Not Required N
GLOW Latest version 11 Not Supported Not Supported Not Required Not Required N
GoWMU (Luminus) it is recommended that you stay up to date with the most recent version 9 - 11 it is recommended that you stay up to date with the most recent version it is recommended that you stay up to date with the most recent version Not Required Not Required N
ISSM 34 11 Not Supported Not Supported Supported Supported Y
IT Direct Latest 11 Not supported Latest Not Required Not Required N
Journal Entry Spreadsheet (JES) Latest version 11 Not Supported Not Supported Supported Supported Y
Kronos 35+ 11 9 41+ Supported Supported Y
Mediasite Latest Latest Latest Latest Not Required Not Required N
Peoplesoft Latest Latest Latest Latest Not Required Not Required N
Pinnacle (7.3) 60 11 not supported 67 Supported Supported Y
TouchNet (Payment and Account Information) Current Version and previous 2 version Current Version and previous 2 version Current Version and previous 2 version Current Version and previous 2 version Supported Supported Y
VPN (vpn.wmich.edu) 3. or higher 7, 8, 9, 10 5, 5.1, 6        
Voicemail Web Inbox         Supported Supported Y
W-Exchange Latest version 11 or higher Latest two version Latest version Not Required Not Required N
Webnow (Web version of Imagenow) Firefox 3.x-17 7.x, 8.x, or 9.x Safari 5.0.x   Supported Supported Y

Desktop and Server Applications

ApplicationVPNGoVPNVPN Required*
Remote Desktop Supported Supported Y
Departmental File Shares Supported Supported Y